Software Updates & Patches
Scheduled for August 21, 2024 at 1:30 PM – 5:01 PM
Completed
August 21, 2024 at 5:01 PMCompleted
August 21, 2024 at 5:01 PMWe have completed the maintenance, the service has returned back to a normal status. If you have any issues, please reach out to our team.
In progress
August 21, 2024 at 1:30 PMIn progress
August 21, 2024 at 1:30 PMMaintenance is now in progress