PFM Host - Hurricane Milton - Florida Impact – Incident details

Hurricane Milton - Florida Impact

Resolved
Operational
Started about 2 months agoLasted 5 days

Affected

Virtual Private Servers

Operational from 10:53 PM to 8:31 PM

Tampa, FL

Operational from 10:53 PM to 8:31 PM

Tampa - 1

Operational from 10:53 PM to 8:31 PM

Tampa - 2

Operational from 10:53 PM to 8:31 PM

Tampa - 3

Operational from 10:53 PM to 8:31 PM

Tampa - 4

Operational from 10:53 PM to 8:31 PM

Updates
  • Resolved
    Resolved

    Our infrastructure has not sustained any damage, and we remain fully operational. This post is intended for informational purposes only.

  • Monitoring
    Monitoring

    We are closely monitoring Hurricane Milton and its potential impact on our Tampa servers. Our team will provide updates here should any service disruptions occur. Please note that automated outage notifications have been temporarily disabled, as minor network interruptions may happen during this period. The hurricane is expected to impact the area on October 9th.